Suivez-nous

Internet

WordPress : c’est la fête des plugins

Depuis les dernières mises à jour WordPress, la 3.8.3 puis la 3.9, qui sont intervenues récemment et de façon assez rapprochée, on dirait que les éditeurs de plugins ont un peu de mal à suivre.

Il y a

  

le

 

Par

Ceci est d’autant plus vrai depuis que WordPress se met à jour automatiquement (depuis la 3.8.1 si ma mémoire est bonne).

En deux jours consécutifs j’ai déjà dû désactiver deux extensions qui non seulement ne fonctionnaient plus, mais qui en plus créaient des problèmes sur le fonctionnement général du site. Sûrement une coïncidence, mais ça fait plutôt une fréquence élevée en 24h, et c’est pour cela que je vous en parle.

Les coupables : Rel Nofollow Checkbox et Simply Exclude. Attention, je ne jette pas la pierre aux créateurs de ces plugins : l’art est difficile et se tenir à jour en permanence n’est pas toujours aisé quand on fait ça en plus de son job, souvent par passion ou nécessité personnelle. On ne remerciera jamais assez les développeurs – souvent bénévoles – pour les services qu’ils rendent à la communauté. Attendons juste les mises à jour.

Le bug de la première rendait inopérante la fenêtre de dialogue d’ajout de liens dans un post, et donc impossible d’ajouter un lien dans un article. Quant à la deuxième, le bug annihilait purement et simplement le fonctionnement des liens de la pagination du site, renvoyant systématiquement une erreur 404 quand on cliquait sur un numéro de page. Super pour le SEO puisque en gros le site n’avait plus qu’une page pour Google : la home (avec quand même ses liens vers les articles en une).

Hop, désactivées direct. Je suis comme ça moi, je tranche dans le vif, comme dirait mon boucher-charcutier (traiteur). Afin de remplacer Simply Exclude pour l’exclusion de catégories dans le flux RSS, je passe par un petit bout de code dans le fichier functions.php, trouvé ici grâce à Jonathan, un collègue lyonnais créateur de WP-Rocket, un plugin de cache de très bonne réputation (que je n’ai pas encore testé, en revanche).

Quel sera le prochain plugin qui viendra compléter la liste des incompatibles avec les dernières versions de WordPress ? Les paris sont ouverts. En attendant, si vous avez des exemples de votre côté, soyez gentils de les partager dans les commentaires, ça peut toujours servir.

 

Newsletter 🍋 Inscrivez-vous à la newsletter tout juste sortie du four, rien que pour vous

8 Commentaires

8 Commentaires

  1. Crunch

    24 avril 2014 at 15 h 33 min

    Bonjour Éric,

    J’ai eu le même problème avec Rel Nofollow Checkbox et l’auteur a corrigé ce bug plus qu’embêtant. Ainsi, le plugin tourne sans problème sous mon WordPress 3.9.

    À bientôt

  2. MarcoAix

    24 avril 2014 at 18 h 19 min

    Oui, ces mises à jour automatiques ce n’est pas génial pour les plugins.
    Même si en l’occurrence le saut vers la 3.9 n’était pas en auto…

  3. onemesh

    24 avril 2014 at 18 h 26 min

    On peut toujours désactiver la mise à jour automatique de wordpress.
    Comme ça, ça laisse le temps de tester la compatibilité des nouvelles versions de WordPress avec les plugins.

  4. faisslam

    24 avril 2014 at 18 h 36 min

    il ya beaucoup des plugins qui marche pas , surtout avec moi avec mon site web version arabic

  5. JeRetiens

    24 avril 2014 at 19 h 26 min

    Je ne sais pas si c’est dû à la mise à jour WP (je crois quand même que si ?), mais lorsque je poste mon article du jour et que je le partage sur FB, la preview ne fonctionne pas une fois sur 3 ou 4, que ça soit la preview image ou preview texte… c’est totalement random :-/

    De plus, ça fait trois fois que j’écris ce commentaire (là je copie colle :p) parce que quand je presse le citron, j’ai une erreur de timeout ! (Coïncidence ? Je ne crois pas :p)

  6. Fabrice

    25 avril 2014 at 9 h 17 min

    Bonjour Eric,
    Effectivement de jolies (mauvaises) surprises avec cette màj, sur les plugins. Problème rencontrés sur certains antispams.

    On peut toutefois empêcher ces mises à jour automatiques en ajoutant dans le fichier de configuration wp-config.php: define( ‘AUTOMATIC_UPDATER_DISABLED’, true );

  7. isabelle

    25 avril 2014 at 19 h 14 min

    bonjour
    On peut toutefois empêcher ces mises à jour automatiques en ajoutant dans le fichier de configuration wp-config.php: define( ‘AUTOMATIC_UPDATER_DISABLED’, true );
    en theorie !
    en pratique n’en tient malheureusement pas compte !!!

  8. Wolf

    26 avril 2014 at 9 h 18 min

    Pour l’instant je n’ai pas fait la mise à jour en 3.9. J’attends consciencieusement que les problèmes soient résolus avant.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Les bons plans 🔥

Dernières news

Newsletter 🍋 Inscrivez-vous à la newsletter tout juste sortie du four, rien que pour vous

Advertisement RED by SFR

Les tests